[Xcode 8 beta 1] xcodebuild test hangs when piped to tee or xcpretty

Originator:minsangkim
Number:rdar://26872644 Date Originated:6/17/2016
Status:Open Resolved:
Product:Developer Tools / Xcode Product Version:8.0 beta 1
Classification: Reproducible:100%
 
Summary:
When running tests from command line via `xcodebuild test` if you pipe the output via `tee` or something else (ex. xcpretty), it hangs indefinitely.

Steps to Reproduce:
1. Start a new project in xcode 8. no need to add any code.
2. from the command line type:
3. xcodebuild test -project XcodebuildHang.xcodeproj -scheme XcodebuildHang -destination 'platform=iOS Simulator,name=iPhone 6,OS=latest' | tee /tmp/test.log


Expected Results:
outputs "** TEST SUCCEEDED **"

and

the xcodebuild output gets piped to /tmp/test.log


Actual Results:
no output of **TEST SUCCEEDED **
command never exits, so it hangs forever

Version:
8 beta 1, El Capitan 10.11.4 (15E65)


Configuration:
MacBook Pro (Retina, 15-inch, Mid 2014)
2.8 GHz Intel Core i7
16 GB 1600 MHz DDR3

Attachments:
'XcodebuildHang.zip' was successfully uploaded.
https://www.dropbox.com/s/5f9g9lebgkc2u0p/XcodebuildHang.zip?dl=0

Duplicates

Number Status Originator Product Title
rdar://27595098 Duplicate/26872644 michael.furtak Developer Tools `xcodebuild build test` hangs indefinitely when piped to another command

Comments

Fixed as of beta 4

Just got a response from Apple on this:

State: Closed Product:

Duplicate of 27558326 (Open or Closed; log in to see the actual state)

By minsangkim at Aug. 2, 2016, 2:26 p.m. (reply...)

Please note: Reports posted here will not necessarily be seen by Apple. All problems should be submitted at bugreport.apple.com before they are posted here. Please only post information for Radars that you have filed yourself, and please do not include Apple confidential information in your posts. Thank you!