10.13 (17A315i) First-run wizard hangs when Wi-Fi is off

Originator:jm
Number:rdar://33727035 Date Originated:4 Aug 2017
Status:Open Resolved:
Product:macOS + SDK Product Version:10.13 (17A315i)
Classification:Crash/Hang/Data Loss Reproducible:Always
 
Area:
Installation

Summary:
On the first boot of macOS High Sierra, the user is asked to log in with their Apple ID. However, if Wi-Fi had been turned off before the upgrade or installation, the connection wizard will freeze/hang.

Steps to Reproduce:
1. Install macOS High Sierra.
2. Before the set-up reboots your Mac, while still in the old system, disable Wi-Fi from the menu bar icon.
3. Wait until the installation is done and the first-run wizard appears.

Expected Results:
macOS should detect that Wi-Fi has been turned off, and ask the user if they would like to turn it back on, in order to sign in with their Apple ID.

Observed Results:
After choosing the sign-in option for Apple ID, the first-run wizard will freeze.
The only way to continue working is to hard-reset the Mac by holding the Power button for longer than 5 seconds and powering it back on afterwards.

Version:
macOS High Sierra 10.13 Developer Beta (17A315i)

Notes:
Please see attached what the wizard looks like when it freezes. Taking the screenshot was still possible.
Please note: The progress spinner icon is not animated in this window.

Comments

J.M.

August 22 2017, 10:37 PM I need to wait with the sysdiagnose until you publish the next Developer Beta.

Apple Developer Relations

August 22 2017, 5:49 PM Engineering has requested the following information regarding your bug report:

Please take a sysdiagnose when this happens and attach it to your bug report. macOS Install Logging Instructions: https://developer.apple.com/services-account/download?path=/OS_X/OS_X_Logs/Install_Logging_Instructions.pdf


For a complete list of logging instructions visit: https://developer.apple.com/bug-reporting/profiles-and-logs/

J.M.

August 7 2017, 8:35 PM This is the current Logs.zip - but I am installing the Developer Beta 5 later and will provide new logs afterwards - if the issue still exists. Logs.zip 6.1 MB

Apple Developer Relations

August 4 2017, 11:52 PM Engineering has requested the following information in order to further investigate this issue:

Please collect Install logs and attach them to your bug report.

macOS Install Logging Instructions: https://developer.apple.com/services-account/download?path=/OS_X/OS_X_Logs/Install_Logging_Instructions.pdf


For a complete list of logging instructions visit: https://developer.apple.com/bug-reporting/profiles-and-logs/


Please note: Reports posted here will not necessarily be seen by Apple. All problems should be submitted at bugreport.apple.com before they are posted here. Please only post information for Radars that you have filed yourself, and please do not include Apple confidential information in your posts. Thank you!