UISearchDisplayDelegate methods are incorrectly named

Originator:basil
Number:rdar://11361115 Date Originated:2/5/2012
Status:Open Resolved:No
Product:iOS SDK Product Version:5
Classification:Enhancement Reproducible:Always
 
Summary:
There is a section of UISearchBarDelegate methods which contain the word 'Clicked' in their names.

This is inconsistent with other method names in iOS where it is common to use the verb, 'Touched'.

- (void)searchBarBookmarkButtonClicked:(UISearchBar *)searchBar
- (void)searchBarCancelButtonClicked:(UISearchBar *)searchBar
- (void)searchBarResultsListButtonClicked:(UISearchBar *)searchBar
- (void)searchBarSearchButtonClicked:(UISearchBar *)searchBar

Comments


Please note: Reports posted here will not necessarily be seen by Apple. All problems should be submitted at bugreport.apple.com before they are posted here. Please only post information for Radars that you have filed yourself, and please do not include Apple confidential information in your posts. Thank you!