hiutil 1.3 does not successfully parse valid html

Number:rdar://12326432 Date Originated:09/18/12
Status:Open Resolved:
Product:hiutil Product Version:1.3
Classification:Other Bug Reproducible:Always
18-Sep-2012 10:07 PM Zacharias Pasternack:
Summary: Using hiutil 1.3, parsing fails on the most basic HTML, causing errors and failure to create index

Steps to Reproduce:
1. Create a folder called Help.
2. Inside the Help folder place attached sample.html file.
3. Run hiutil 1.3, as follows:
$ hiutil -a --create Help/ --file Help/Help.helpindex -vvv

Expected Results:
Valid help index created.

Actual Results:
hiutil reports errors (see below) and the file is not fully indexed.
sample.html -- Parse error: The operation couldn’t be completed. (NSXMLParserErrorDomain error 76.)
sample.html -- Parse error: Error 76, Description: (null), Line: 8, Column: 8
sample.html -- Finished parsing

This occurs in Mac OS X Mountain Lion with hiutil 1.3.
This does NOT occur in Mac OS X Lion with hiutil 1.2.


18-Sep-2012 10:07 PM Zacharias Pasternack:
'sample.html' and 'iMac.spx' were successfully uploaded


Any chance we could get a look at sample.html?


Hmm, I can't seem to get HTML in a comment here. HTML in the SO question I posted, here: http://stackoverflow.com/questions/12473402/hiutil-not-indexing-properly-in-mountain-lion/15043055#15043055

By zacharias.pasternack at March 2, 2013, 9:53 p.m. (reply...)

Please note: Reports posted here will not necessarily be seen by Apple. All problems should be submitted at bugreport.apple.com before they are posted here. Please only post information for Radars that you have filed yourself, and please do not include Apple confidential information in your posts. Thank you!